Sync gives error "unexpected error" during mounts command

sync gives error “unexpected error” during mounts command

Hi @dfimdkoxygen

Can you try using the latest Sync Toolkit that just came out (see the post here) and try again? Let us know if that fixes the issue you’re seeing.

Thanks,
-Jeff

@dfimdkoxygen,

Since this is a major upgrade, I’d actually recommend doing the following once you’ve unpacked the new toolkit package.

Upgrade instructions:

  1. Shutdown the explorer toolkit’s cloudd using its stop.sh script.
  2. Shutdown the sync toolkit’s syncd using its stop.sh script.
  3. At this point, you can download the new explorer toolkit and sync toolkit packages if you haven’t already done so and then uncompress them.
  4. Remove the .oxygen and .gateway folders from your home directory.
  5. Start up the new explorer toolkit’s cloudd using its stop.sh script.
  6. Start up the new sync toolkit’s syncd using its stop.sh script.

You’ll need to reconnect your storage using the explorer toolkit’s authorize command again due to step #4 above. Thanks, and let us know if this works or not.

-Jeff

Thank you so much for prompt help. I downloaded all the latest versions after uninstalling explorer, sync and infinity drive and deleting all those folders. Installed everything again first explorer and sync and then infinity drive. Now I get the same error when I try to add a mount like in this command “mounts add i:/x /google_drive/dfimdkgeneral@gmail.com/dfimdkgeneral/d1 hourly”. After that I tried mounts command to see the list and actually it seems the mount was added correctly except for the refresh rate which is picked up as manual despite having given as hourly in my command earlier.

By the way, it is a fantastic product and very helpful. Keep it up!

Thanks again.

Hi @dfimdkoxygen,

I was able to confirm the issue and worked with our engineering team on a fix. Can you try the new build mentioned in this post and try it out again?

Thanks for your patience, and we appreciate that you’re using our stuff and providing feedback.

Best,
-Jeff