Request Refused on Upload Sync

Hello,

I’m using the IT Tools in Windows 10 Pro. I’ve successfully authorized Onedrive and created a mount. When I set it syncing it appears to fully upload the file then fails. If I check failures, it says request refused. Same for all the files. I’ve tried retrying, same problem.

Hi @Twig,

Thanks for reaching out with your issue. We’re looking into it. As a quick sanity test, I was able to connect to my OneDrive storage and create a sync mount there and see files upload fine, so I want to dig down deeper and get some more information.

Let’s first confirm that the OneDrive account is fine:

  1. Are you able to upload one of the failed files to another folder on your remote OneDrive storage using the OneDrive web client?
  2. Can you try using the Explorer Toolkit to upload one of the failed files to OneDrive? You can use the explore command line utility (which you used earlier to connect your OneDrive storage) with the upload command.

There’s also a log file which you can send to support@oxygencloud.com for us to look at. If you go to the %userprofile%\.oxygen\logs folder and send us your onedrive.log file, that would be helpful.

Thanks,
-Jeff

Hi Jeff,

Thanks for getting back to me so promptly. So I did a little more testing. I cleared the log down and removed and added my mount. I then successfully uploaded a 1 line text file (log line 6) by sync and also a ~500mb file(log line 11). I then tried a 2.7Gb file (log line 16). This failed, it then posts again (log line 12) then has issues again at line 432. In monitor it looked like it had started again from the beginning. I’ve e-mailed you the log to take a look at.

I also tried uploading using Explore as well. Similar problem except this time it said broken connection. I’m wondering if because it takes so long to upload then if there’s any transient network issues it then fails or something? I’ve got a 10Mb upload connection so it’s managing about 1.5mb/s.

Twig

Weirdly, it seems like it did upload the file after all - but for some reason it thought it hadn’t. I’ll try another one.

Hi Twig,

The issue can be the OneDrive account, our integration with OneDrive, or Sync. Can you upload the 2.7GB file into OneDrive using the OneDrive web client? Did it work? Also, are you using OneDrive or OneDrive for Business or Sharepoint?

-peter

Works ok with Windows OneDrive client - tested with the same file. I am using personal OneDrive - ah misread your post, I’ll try the web client tonight.

If it works with OneDrive desktop client, then your OneDrive account is probably not the issue.

Can you try uploading the 2.7GB file with explore? Also, have you tried Oxygen Drive?

BTW, can you share your use case for more context? Why use toolkit versus the OneDrive sync client?

thanks
-peter

I am backing-up CCTV footage and have written some scripts to process the video so I get a rolling back-up. I’ve changed the scripts to split into 500mb chunks now and it seems to work fine.

Thank you for your help!

Cool. Let us know if there is any enhancement that can make your use case easier.

Are you using the offload functionality with sync? You can automatically remove synchronized files from local storage to clear disk space. https://docs.oxygencloud.com/docs/cli-sync-offload